ALM-12067 Tomcat Resource Is Abnormal
Alarm Description
HA checks the Tomcat resources of Manager every 85 seconds. This alarm is generated when HA detects that the Tomcat resources are abnormal for two consecutive times.
This alarm is cleared when HA detects that the Tomcat resources become normal.
Resource Type of Tomcat is Single-active. Active/standby will be triggered upon resource exceptions. When this alarm is generated, the active/standby switchover is complete and new Tomcat resources have been enabled on the new active Manager. In this case, this alarm is cleared. This alarm is used to notify users of the cause of the active/standby Manager switchover.
In MRS 3.3.1 and later versions, the alarm name is changed from "Tomcat Resource Is Abnormal" to "Abnormal Tomcat Resources of Manager".
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
12067 |
Major |
Yes |
Alarm Parameters
Parameter |
Description |
---|---|
Source |
Specifies the cluster or system for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
RoleName |
Specifies the role for which the alarm was generated. |
HostName |
Specifies the host for which the alarm was generated. |
Impact on the System
An active/standby Manager switchover may occur. The Manager and component web UIs are unavailable. The cluster management function cannot be provided for upper-layer web applications, and users may fail to log in to the Manager and component web UIs.
Possible Causes
- The Tomcat directory permission is abnormal, and the Tomcat process is abnormal.
Handling Procedure
Check whether the permission on the Tomcat directory is normal.
- In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and click to view the IP address of the host for which the alarm is generated.
- Log in to the alarm host as user root.
- Run the su - omm command to switch to user omm.
- Run the vi $BIGDATA_LOG_HOME/omm/oms/ha/scriptlog/tomcat.log command to check whether the Tomcat resource log contains keyword Cannot find XXX and rectify the file permission based on the keyword.
- After 5 minutes, check whether the alarm is automatically cleared.
- If yes, no further action is required.
- If no, go to 6.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- In the Services area, select OmmServer and Tomcat, and click OK.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot