Updated on 2023-01-17 GMT+08:00

Full Phase Error: shard table=*** failed

Scenarios

During a full migration or synchronization, an error is reported, and the log information is as follows: service DATAMOVE failed, cause by: shard table=`%s`.`%s` failed

Possible Causes

The source database performance is insufficient or the network is unstable. As a result, the source database sharding times out.

Solution

  1. Check whether the task is normal.

    • If the task is normal, this error is recorded in the log and no further action is required.
    • If the task is abnormal, go to 2.

  2. In the upper right corner of the console, choose Service Tickets > Create Service Ticket and contact DRS customer service.