Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-50227 Concurrent Doris Tenant Queries Exceeds the Threshold
Updated on 2024-11-29 GMT+08:00

ALM-50227 Concurrent Doris Tenant Queries Exceeds the Threshold

Alarm Description

The system checks concurrent tenant queries on FE nodes every 30 seconds. This alarm is generated when the number exceeds the threshold (90% by default).

This alarm is cleared when the number of concurrent queries from the FE nodes falls below the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

50227

Major

Quality of service

Doris

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Additional Information

Detail

Specifies the alarm triggering condition.

Impact on the System

Too many concurrent queries consume a large number of system resources. This leads to slow response and even request rejection.

Possible Causes

There is a large amount of service requests.

Handling Procedure

Check the actual number of concurrent tenant queries on FE nodes.

  1. Log in to FusionInsight Manager and choose O&M > Alarm > Alarms. In the alarm list, view the role name and obtain the IP address of the instance in Location of the alarm whose ID is 50227.
  2. Choose Cluster > Services > Doris > Instances, select the FE instance for which the alarm is generated, and click Chart. Click Tenant Resource in the Chart Category pane, and check whether the actual number of concurrent queries in the Number of Concurrent Tenant Queries chart is greater than the threshold. The default value is 90%.

    • If yes, go to 3.
    • If no, go to 5.

  3. Check whether a large number of tasks were being executed during the alarm period.

    • If yes, go to 4.
    • If no, go to 5.

  4. On FusionInsight Manager, choose O&M > Alarm > Thresholds > Name of the desired cluster > Doris > Tenant Resources. Increase the threshold value and trigger counts based on service requirements. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 5.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select Doris for the target cluster.
  3. Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the abnormal host, and click OK.
  4. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  5. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.