ALM-27003 DBService Heartbeat Interruption Between the Active and Standby Nodes
Alarm Description
This alarm is generated when the active or standby DBService node has not received heartbeat messages from the peer node for 7 seconds.
This alarm is cleared when the heartbeat recovers.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
27003 |
Major |
Heartbeat |
FusionInsight Manager |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Additional Information |
Local DBService HA |
Specifies a local DBService HA. |
Peer DBService HA |
Specifies a peer DBService HA. |
Impact on the System
During the DBService heartbeat interruption, only one node can provide the service. If this node is faulty, no standby node is available for failover and the service is unavailable.
Possible Causes
The link between the active and standby DBService nodes is abnormal.
Handling Procedure
Check whether the network between the active and standby DBService servers is normal.
- In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and click to view the IP address of the standby DBService server for which the alarm is generated.
- Log in to the active DBService server as user root.
- Run the ping heartbeat IP address of the standby DBService command to check whether the standby DBService server is reachable.
- Contact the network administrator to check whether the network is faulty.
- Rectify the network fault and check whether the alarm is cleared from the alarm list.
- If yes, no further action is required.
- If no, go to 6.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select the following services for the target cluster
- DBService
- Controller
- NodeAgent
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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