ALM-24013 Flume MonitorServer Certificate File Is Invalid or Damaged
Alarm Description
MonitorServer checks whether its certificate file is valid (whether the certificate exists and whether the certificate format is correct) every hour. This alarm is generated when the certificate file is invalid or damaged. This alarm is automatically cleared when the certificate file becomes valid again.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
24013 |
Major |
Error handling |
MonitorServer |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
The Flume client cannot access the Flume server.
Possible Causes
The MonitorServer certificate file is invalid or damaged.
Handling Procedure
View alarm information.
- Log in to FusionInsight Manager and choose O&M. In the navigation pane on the left, choose Alarm > Alarms. On the page that is displayed, locate the row containing ALM-24013 MonitorServer Certificate File Is Invalid or Damaged, and view the Location information. View the IP address of the instance for which the alarm is generated.
Check whether the certificate file in the system is valid. If it is not, generate a new one.
- Log in to the node for which the alarm is generated as user root and run the su - omm command to switch to user omm.
- Run the following command to go to the MonitorServer certificate file directory:
cd ${BIGDATA_HOME}/FusionInsight_Porter_*/install/FusionInsight-Flume-*/flume/conf
- Run the ls -l command to check whether the ms_sChat.crt file exists:
- Run the openssl x509 -in ms_sChat.crt -text -noout command to check whether certificate details are displayed.
- Run the following command to go to the Flume script directory:
cd ${BIGDATA_HOME}/FusionInsight_Porter_*/install/FusionInsight-Flume-*/flume/bin
- Run the following command to generate a new certificate file. Then check whether the alarm is automatically cleared one hour later.
sh geneJKS.sh -m Custom password of the MonitorServer certificate on the server -n Custom password of the MonitorServer certificate on the client
- If yes, go to 8.
- If no, go to 9.
The custom certificate passwords must meet the following complexity requirements:
- Contain at least four types of uppercase letters, lowercase letters, digits, and special characters.
- Contain 8 to 64 characters.
- Be changed periodically (for example, every three months), and certificates and trust lists are generated again to ensure security.
- Check whether this alarm is generated again during periodic system check.
- If yes, go to 9.
- If no, no further action is required.
Collect the fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Select MonitorServer in the required cluster for Service.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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