Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-16000 Percentage of Sessions Connected to the HiveServer to Maximum Number Allowed Exceeds the Threshold
Updated on 2024-11-29 GMT+08:00

ALM-16000 Percentage of Sessions Connected to the HiveServer to Maximum Number Allowed Exceeds the Threshold

Alarm Description

The system detects the percentage of sessions connected to the HiveServer to the maximum number of allowed sessions every 30 seconds. This indicator can be viewed on the Cluster > Name of the desired cluster > Services > Hive > Instance > HiveServer instance. This alarm is generated when the percentage exceeds the default value.

To change the threshold, choose O&M > Alarm > Thresholds > Name of the desired cluster > Hive > Percentage of Sessions Connected to the HiveServer to Maximum Number of Sessions Allowed by the HiveServer.

When the Trigger Count is 1, this alarm is cleared when the percentage is less than or equal to the threshold. When the Trigger Count is greater than 1, this alarm is cleared when the percentage is less than or equal to the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

16000

Versions earlier than MRS 3.3.0: minor (default threshold: 90%)

MRS 3.3.0 and later versions:

Critical (default threshold: 90%)

Major (default threshold: 80%)

Quality of service

Hive

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Additional Information

Trigger Condition

Specifies the threshold for triggering the alarm.

Impact on the System

If a connection number alarm is generated, the number of sessions connected to HiveServer is too large. As a result, new connections cannot be established, new tasks fail, or even services restart unexpectedly.

Possible Causes

Too many clients are connected to HiveServer.

Handling Procedure

Increase the maximum number of connections to Hive.

  1. On the FusionInsight Manager portal, Choose Cluster > Name of the desired cluster > Services > Hive > Configurations >All Configurations.
  2. Search for hive.server.session.control.maxconnections and increase the value of this parameter. If the value of this parameter is A, the threshold is B, and the number of sessions connected to the HiveServer is C, adjust the value of this parameter according to A x B > C. To view the number of sessions connected to the HiveServer, check the value of Statistics for Sessions of the HiveServer on the Hive monitoring page.
  3. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 4.

Collect fault information.

  1. On the FusionInsight Manager portal, choose O&M > Log > Download.
  2. Select Hive in the required cluster from the Service.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact the O&M engineers and send the collected logs.

Alarm Clearance

After the fault is rectified, the system automatically clears this alarm.

Related Information

None.