How Are Collection Node or Collection Channel Faults Handled?
Symptom
The component controller isap-agent periodically reports the collection node status and collection channel health status. Despite a delay of about one minute, the Health Status of a collection node or collection channel was still displayed as Faulty 3 minutes after the collection channel is delivered, and the CPU usage or memory usage of the server is about to reached 100%.
Possible Causes
The configured connector or parser has syntax or semantic errors. As a result, the collector cannot run properly and restarts over and over again. The CPU and memory are exhausted.
Fault Location
- Remotely log in to the ECS where the collection node resides.
- Log in to the ECS console, locate the target server, and click Remote Login in the Operation column to log in to the server. For details, see Login Using VNC.
- If your server has an EIP bound, you can also use a remote management tool, such as PuTTY or Xshell, to log in to the server and install the component controller on the server as user root.
- Run the following command to check the OS running status:
If the following information is displayed, the Java process in the ECS uses a large number of CPU resources.
Figure 3 Status
- Run the following command to view the collector run logs:
According to the logs, the filter (parser) configuration of the current collection channel is incorrect, as shown in the following figure.
Figure 4 Collector run log
- Run the following command to switch to the directory where the collection channel configuration file is stored:
- Run the following command to check whether the filter part is abnormal:
If the information shown in the following figure is displayed, the current filter is abnormal.
Figure 5 Filter exceptions
Solution
- Log in to the SecMaster console and access the target workspace.
- In the navigation pane on the left, choose Parsers tab. . Then, select the
- Click Edit in the Operation column of the row containing the target parser. On the edit page, delete the incorrect configuration and configure it again.
Figure 6 Configurations of an abnormal parser
Figure 7 Modifying the parser configuration
- Click OK.
- Click the Collection Channels tab, locate the target connection channel, and click Restart in the Operation column.
Figure 8 Restarting a collection channel
- Check the status of the collection channel and collection node.
- After the restart is complete, go to the Collection Channels tab and check the health status of the target collection channel.
Figure 9 Health status of a collection channel
- Select the Collection Nodes tab. On the page displayed, check the health status of the target collection node.
Figure 10 Health status of a collection node
If the Health Status of the collection channel and collection node is Normal, the fault has been rectified.
- After the restart is complete, go to the Collection Channels tab and check the health status of the target collection channel.
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