Help Center/ Data Lake Insight/ FAQs/ DLI Databases and Tables/ Why Am I Unable to Query a Table on the DLI Console?
Updated on 2024-11-15 GMT+08:00

Why Am I Unable to Query a Table on the DLI Console?

Symptom

A DLI table exists but cannot be queried on the DLI console.

Possible Causes

If a table exists but cannot be queried, there is a high probability that the current user does not have the permission to query or operate the table.

Solution

Contact the user who creates the table and obtain the required permissions. To assign permissions, perform the following steps:

  1. Log in to the DLI management console as the user who creates the table. Choose Data Management > Databases and Tables form the navigation pane on the left.
  2. Click the database name. The table management page is displayed. In the Operation column of the target table, click Permissions. The table permission management page is displayed.
  3. Click Set Permission. In the displayed dialog box, set Authorization Object to User, set Username to the name of the user that requires the permission, and select the required permissions. For example, Select Table and Insert permissions.
  4. Click OK.
  5. Log in to the DLI console as the user that has been granted permission and check whether the table can be queried.