Help Center/ Cloud Container Engine/ FAQs/ Networking/ Network Exception Troubleshooting/ What Should I Do If Status Code 308 Is Displayed When the Nginx Ingress Controller Is Accessed Using the Internet Explorer?
Updated on 2024-11-13 GMT+08:00

What Should I Do If Status Code 308 Is Displayed When the Nginx Ingress Controller Is Accessed Using the Internet Explorer?

Symptom

After the Nginx Ingress Controller is upgraded, existing services cannot be accessed by Using the Internet Explorer, and the status code is 308.

Possible Causes

After the Nginx Ingress Controller is upgraded, the default permanent redirection status code changes from 301 to 308. However, Internet Explorer of some earlier versions does not support this code. As a result, the Nginx Ingress Controller cannot be accessed.

Nginx Ingress Controller community issue: https://github.com/kubernetes/ingress-nginx/issues/1825

Solution

When creating an Ingress, you can use the nginx.ingress.kubernetes.io/permanent-redirect-code annotation to specify that the permanent redirection status code is 301.

An example is as follows:

apiVersion: networking.k8s.io/v1
kind: Ingress 
metadata: 
  name: ingress-test
  namespace: default
  annotations:
    nginx.ingress.kubernetes.io/permanent-redirect-code: '301'
...