How Do I Fix Startup Failures of a Windows Target Server After the Migration?
Symptom
After the migration, the Windows target server cannot be started, even in safe mode.
Possible Causes
The KVM driver or KVM registry is missing.
Solutions
- Solution 1
- Create a temporary ECS in the same region and AZ as the target server. Detach the system disk from the target server and attach it to the temporary ECS.
- Check for the KVM driver.
- Check whether files viostor.sys and vioscsi.sys exist in the Windows\System32\drivers directory of the disk.
- Check whether files viostor.cat and vioscsi.cat are in the Windows\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE} directory of the disk.
- Check whether files viostor.inf and vioscsi.inf are in the Windows\System32\drivers directory of the disk.
If any of the preceding files is missing, on the temporary ECS. Copy the desired file to the corresponding directory on the system disk of the target server.
The .sys, .cat, and .inf files are used in pairs. You need to copy a file pair, not just a single file.
- Check the registry.
- Open the Registry Editor and click HKEY_LOCAL_MACHINE in the navigation pane on the left.
- On the menu bar, choose File > Local Hive, locate registry C:\Windows\System32\config\SYSTEM, and change its name from SYSTEM to p2v.
- Open the registry and check whether entries p2v/ControlSet001/services/viostor and p2v/ControlSet001/services/vioscsi are there.
If they do not, manually add them to the registry by referring to the registry of the temporary ECS.
- Stop the temporary ECS, and attach the disk as the system disk to the target server. Then restart the target server.
- Method 2
on the source server and then perform a synchronization to the target server.
After the UVP Tools are installed, do not restart the source server, or the synchronization will fail.
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