Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Actualización más reciente 2023-11-20 GMT+08:00

ALM-43013 Tiempo de JDBCServer GC excede el umbral (Para MRS 2.x o anterior)

Descripción

El sistema comprueba el tiempo de GC del proceso JDBCServer cada 60 segundos. Esta alarma se genera cuando el tiempo GC detectado excede el umbral (12 segundos) durante tres veces consecutivas. Puede cambiar el umbral seleccionando System > Threshold Configuration > Service > Spark > JDBCServer GC Time > Total JDBCServer GC Time. Esta alarma se borra cuando el tiempo GC de JDBCServer es menor o igual que el umbral.

Atributo

ID de alarma

Severidad de alarma

Borrado automáticamente

43013

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Si el tiempo GC excede el umbral, JDBCServer puede ejecutarse con bajo rendimiento.

Causas posibles

La memoria heap del proceso JDBCServer se usa en exceso o se asigna de forma inapropiada, lo que causa GC frecuente.

Procedimiento

  1. Comprueba la hora del GC.

    1. Vaya a la página de detalles del clúster y elija Alarms.
    2. Seleccione la alarma cuyo Alarm ID sea 43013 y vea la dirección IP y el nombre del rol de la instancia de Location.
    3. Elija Components > Spark > Instance > JDBCServer (Dirección IP de la instancia para la que se genera la alarma) > Customize > GC Time of the JDBCServer Process. Haga clic en OK para ver la hora de GC.
    4. Compruebe si el tiempo de GC del proceso JDBCServer es superior a 12 segundos.
      • En caso afirmativo, vaya a 1.e.
      • Si no, vaya a 2.
    5. Elija Components >Spark >Service Configuration. Establezca Type en All y elija JDBCServer >Tuning. Aumente el valor del parámetro SPARK_DRIVER_MEMORY según sea necesario.
    6. Verifique si la alarma se ha borrado.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.

  2. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna