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Actualización más reciente 2023-11-20 GMT+08:00

ALM-43011 El uso de memoria no heap del proceso de JDBCServer supera el umbral (Para MRS 2.x o anterior)

Descripción

El sistema comprueba el estado del proceso de JDBCServer cada 30 segundos. La alarma se genera cuando el uso de memoria no heap del proceso de JDBCServer excede el umbral (90% de la memoria máxima).

Atributo

ID de alarma

Severidad de alarma

Borrado automáticamente

43011

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Si la memoria no heap del proceso de JDBCServer disponible es insuficiente, se produce un desbordamiento de memoria y el servicio se interrumpe.

Causas posibles

La memoria no heap del proceso de JDBCServer se utiliza en exceso o la memoria no heap se asigna de forma inapropiada.

Procedimiento

  1. Comprueba el uso de memoria no heap.

    1. Vaya a la página de detalles del clúster y elija Alarms.
    2. Seleccione la alarma cuyo Alarm ID sea 43011 y vea la dirección IP y el nombre del rol de la instancia de Location.
    3. Elija Components > Spark > Instance > JDBCServer (dirección IP de la instancia para la que se genera la alarma) > Customize > Non-heap Memory Statistics of the JDBCServer Process. Haga clic en OK para ver el uso de memoria no heap.
    4. Compruebe si el uso de memoria no-heap de JDBCServer ha alcanzado el umbral (90% de la memoria máxima no-heap).
      • En caso afirmativo, vaya a 1.e.
      • Si no, vaya a 2.
    5. Elija Components >Spark >Service Configuration. Establezca Type en All y elija JDBCServer >Tuning. Aumente el valor de -XX:MaxMetaspaceSize en spark.driver.extraJavaOptions según sea necesario.
    6. Verifique si la alarma se ha borrado.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.

  2. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna