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Actualización más reciente 2023-11-20 GMT+08:00

ALM-43006 El uso de memoria de Heap del proceso de JobHistory supera el umbral (Para MRS 2.x o anterior)

Descripción

El sistema comprueba el estado del proceso de JobHistory cada 30 segundos. La alarma se genera cuando el uso de memoria de heap del proceso de JobHistory excede el umbral (90% de la memoria máxima).

Atributo

ID de alarma

Gravedad de la alarma

Borrado automáticamente

43006

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Si la memoria de heap de proceso de JobHistory disponible es insuficiente, se produce un desbordamiento de memoria y el servicio se interrumpe.

Causas posibles

La memoria de heap del proceso de JobHistory se utiliza en exceso o la memoria de heap se asigna de forma inadecuada.

Procedimiento

  1. Compruebe el uso de la memoria heap.

    1. Vaya a la página de detalles del clúster y elija Alarms.
    2. Seleccione la alarma cuyo Alarm ID sea 43006 y vea la dirección IP y el nombre del rol de la instancia en Location.
    3. Elija Components > Spark > Instance > JobHistory (dirección IP de la instancia para la que se genera la alarma) > Customize > Heap Memory Statistics of the JobHistory Process. Haga clic en OK para ver el uso de memoria de heap.
    4. Compruebe si la memoria de heap utilizada de JobHistory alcanza el 90% de la memoria de heap máxima especificada para JobHistory.
      • En caso afirmativo, vaya a 1.e.
      • Si no, vaya a 2.
    5. Elija Components >Spark >Service Configuration. Establezca Type en All y elija JobHistory >Default. Aumente el valor de SPARK_DAEMON_MEMORY según sea necesario.
    6. Haga clic en Save Configuration y seleccione Restart the affected services or instances. Haga clic en OK.
    7. Verifique si la alarma se ha borrado.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.

  2. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna