Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Actualización más reciente 2023-11-20 GMT+08:00

ALM-18011 Memoria de tareas pendientes de Yarn excede el umbral (Para MRS 2.x o anterior)

Descripción

El sistema comprueba la memoria de las tareas pendientes de Yarn cada 30 segundos y compara la memoria con el umbral. Esta alarma se genera cuando la memoria de tareas pendientes excede el umbral.

Puede cambiar el umbral seleccionando System > Configure Alarm Threshold > Service > Yarn > Queue Root Pending Memory > Queue Root Pending Memory en MRS Manager.

Esta alarma se borra cuando la memoria de las tareas pendientes es menor o igual que el umbral.

Atributo

ID de alarma

Gravedad de la alarma

Borrado automáticamente

18011

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Trigger Condition

Especifica el umbral para activar la alarma.

Impacto en el sistema

Las tareas se pueden apilar y no se pueden procesar de manera oportuna.

Causas posibles

La capacidad de cálculo del clúster es inferior a la tasa de envío de tareas. Como resultado, la tarea no puede procesarse de manera oportuna después de haber sido enviada.

Procedimiento

  1. Compruebe el uso de la memoria y los vCores en la página Yarn.

    Compruebe si los valores de Memory Used|Memory Total y VCores Used|VCores Total en la página nativa de Yarn alcanzan o se acercan a los valores máximos.

    • En caso afirmativo, vaya a 2.
    • Si no, vaya a 5.

  2. Compruebe el número de tareas enviadas.

    Compruebe si las tareas en ejecución se envían con una frecuencia normal.

    • En caso afirmativo, vaya a 3.
    • Si no, vaya a 5.

  3. Escale horizontal el clúster.

    El escalamiento horizontal se basa en los requisitos del sitio. Para obtener más información, consulte Escalamiento manual de un clúster.

  4. Una vez completado el escalamiento horizontal, compruebe si la alarma está desactivada.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 5.

  5. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna