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Actualización más reciente 2023-11-20 GMT+08:00

ALM-14012 Los datos de Journalnode de HDFS no están sincronizados (Para MRS 2.x o anterior)

Descripción

En el NameNode activo, el sistema comprueba la sincronización de datos en todos los JournalNodes del clúster cada 5 minutos. Esta alarma se genera cuando los datos de un JournalNode no están sincronizados con los de otro JournalNodes.

Esta alarma se borra en 5 minutos después de sincronizar los datos de JournalNodes.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

14012

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

IP

Especifica la dirección IP del servicio de la instancia de JournalNode para la que se genera la alarma.

Impacto en el sistema

Cuando un JournalNode funciona incorrectamente, los datos del nodo no se sincronizan con los de otro JournalNodes. Si los datos de más de la mitad de JournalNodes no están sincronizados, el NameNode no puede funcionar correctamente, lo que hace que el servicio HDFS no esté disponible.

Causas posibles

  • La instancia de JournalNode no se ha iniciado o se ha detenido.
  • La instancia de JournalNode funciona incorrectamente.
  • La red del JournalNode es inalcanzable.

Procedimiento

  1. Compruebe si se ha iniciado la instancia de JournalNode.

    1. En la página de detalles del clúster MRS, haga clic en Alarms. En la lista de alarmas, haga clic en la alarma.
    2. En el área Alarm Details, compruebe Location y obtenga la dirección IP del JournalNode para el que se genera la alarma.
    3. Elija Components > HDFS > Instances. En la lista de instancias, haga clic en el JournalNode para el que se genera la alarma y compruebe si Operating Status del nodo es Started.
      • En caso afirmativo, vaya a 2.a.
      • Si no, vaya a 1.d.
    4. Seleccione la instancia JournalNode y elija More > Start Instance para iniciarla.
    5. Espere 5 minutos y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 4.

  2. Compruebe si la instancia de JournalNode funciona correctamente.

    1. Comprueba si Health Status de la instancia de JournalNode es Good.
      • En caso afirmativo, vaya a 3.a.
      • Si no, vaya a 2.b.
    2. Seleccione la instancia JournalNode y elija More > Restart Instance para reiniciarla.
    3. Espere 5 minutos y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 4.

  3. Compruebe si la red del JournalNode es accesible.

    1. En la página de detalles del clúster MRS, elija Components > HDFS > Instances para comprobar la dirección IP del servicio del NameNode activo.
    2. Inicie sesión en el NameNode activo.
    3. Ejecute el comando ping para comprobar si se produce un tiempo de espera o si la red entre el NameNode activo y el JournalNode es inalcanzable.

      ping service IP address of the JournalNode

      • En caso afirmativo, vaya a 3.d.
      • Si no, vaya a 4.
    4. Póngase en contacto con el personal de O&M para rectificar la falla de la red. Espere 5 minutos y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 4.

  4. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna