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Actualización más reciente 2023-11-20 GMT+08:00

ALM-14003 El número de bloques HDFS perdidos supera el umbral (Para MRS 2.x o anterior)

Descripción

El sistema comprueba el número de bloques perdidos cada 30 segundos y compara el número de bloques perdidos con el umbral. El indicador de bloques perdidos tiene un umbral predeterminado. Esta alarma se genera cuando el número de bloques perdidos excede el umbral.

Esta alarma se borra cuando el número de bloques perdidos es menor o igual que el umbral.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

14003

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

NSName

Especifica el servicio NameService para el que se genera la alarma.

Trigger condition

Genera una alarma cuando el valor real del indicador excede el umbral especificado.

Impacto en el sistema

Los datos almacenados en HDFS se pierden. HDFS puede entrar en el modo seguro y no puede proporcionar servicios de escritura. Los datos de bloques perdidos no se pueden restaurar.

Causas posibles

  • La instancia DataNode es anormal.
  • Los datos se eliminan.

Procedimiento

  1. Compruebe la instancia DataNode.

    1. En la página de detalles del clúster MRS, seleccione Components > HDFS > Instances.
    2. Compruebe si el estado de todas las instancias de DataNode es Good.
      • En caso afirmativo, vaya a 3.
      • Si no, vaya a 1.c.
    3. Reinicie la instancia DataNode y compruebe si el reinicio se realiza correctamente.
      • En caso afirmativo, vaya a 2.b.
      • Si no, vaya a 2.a.

  2. Elimine el archivo dañado.

    1. Utilice el cliente en el nodo del clúster. Ejecute el comando hdfs fsck / -delete para eliminar el archivo perdido. A continuación, vuelva a escribir el archivo y recuperar los datos.
    2. Espere 5 minutos y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 3.

  3. Recopile información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna