ALM-50210 Maximum Compaction Score of All BE Nodes Exceeds the Threshold
Alarm Description
The system checks the maximum compaction score of all BE nodes every 30 seconds. This alarm is generated when the maximum compaction score exceeds the threshold (10 by default).
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
50210 |
Major |
Yes |
Alarm Parameters
Parameter |
Description |
---|---|
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Trigger Condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
Query or write may be delayed.
Possible Causes
The number of concurrent service requests is large in the cluster, or the compaction queue is small.
Handling Procedure
Check whether the alarm threshold or alarm trigger count is properly configured.
- Log in to FusionInsight Manager, choose O&M > Alarm > Thresholds, click the name of the desired cluster, and choose Doris > Performance > Maximum compaction score of all BE nodes (BE).
- Click the edit button next to Trigger Count, change the number based on site requirements, and click OK.
- Click Modify in the Operation column, change the alarm threshold based on site requirements, and click OK.
- Wait 2 minutes and check whether the alarm is cleared in the alarm list.
- If yes, no further action is required.
- If no, go to 5.
- Choose Cluster > Services > Doris > Configurations > All Configurations > BE(Role) > Customization, add the max_base_compaction_threads parameter to be.conf with a value of 10, and add the max_cumu_compaction_threads parameter with a value 20.
- Click Save. Click Instances, select the BE instances whose configuration has expired, click More, and select Restart Instance to restart the Doris BE instances.
During BE instance restart, the tasks running on BE nodes will fail. The tasks on BE nodes that are not restarted are not affected.
- Check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 8.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, select Doris for the target cluster, and click OK.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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