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Actualización más reciente 2023-11-20 GMT+08:00

ALM-45736 Servicio Guardian no disponible

Descripción

El módulo de alarma comprueba el estado del servicio Guardian cada 60 segundos. Esta alarma se genera si Guardian no está disponible.

Esta alarma se borra después de que Guardian se recupere.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

45275

Crítica

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Guardian no puede funcionar correctamente.

Causas posibles

  • El servicio HDFS del que depende el servicio Guardian es anormal.
  • La instancia de rol TokenServer es anormal.

Procedimiento

Comprobar el estado de servicio HDFS.

  1. Inicie sesión en FusionInsight Manager y elija O&M > Alarm > Alarms. En la página que se muestra, compruebe si se notifica "ALM-14000 Servicio HDFS no disponible".

    • En caso afirmativo, vaya a 2.
    • Si no, vaya a 3.

  2. Borre esta alarma de acuerdo con la ayuda de alarma.

    Después de que se desactive la alarma, espere unos minutos y compruebe si la alarma GuardianService no disponible está despejado.
    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 3.

Comprobar todas las instancias de TokenServer.

  1. Inicie sesión en el nodo donde reside la instancia TokenServer como usuario omm y ejecute el comando ps -ef|grep "com.huawei.guardian.token.server.Server" para comprobar si el proceso TokenServer existe en el nodo.

    • En caso afirmativo, vaya a 5.
    • Si no, reinicie la instancia de TokenServer defectuosa y vaya a 4.

  2. En la lista de alarmas, compruebe si la alarma "Servicio Guardian no disponible" está desactivada.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 5.

Recopilar información de fallas.

  1. En FusionInsight Manager, elija O&M > Log > Download.
  2. Expanda la lista desplegable Service y seleccione Guardian para el clúster de destino.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 1 hora antes y después del tiempo de generación de alarma, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con y proporcione los registros recopilados.

Eliminación de alarmas

Esta alarma se borra automáticamente después de rectificar la falla.

Información relacionada

Ninguna