ALM-45429 Error de sincronización de metadatos de tabla en el nodo ClickHouse añadido
Esta sección solo se aplica a MRS 3.1.2 o posterior.
Descripción
Esta alarma se genera cuando la tabla local correspondiente a la tabla distribuida no se crea durante la expansión de la capacidad de ClickHouse.
Atributo
ID de alarma |
Severidad de alarma |
Borrar automáticamente |
---|---|---|
45429 |
Grave |
No |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
No se puede consultar la tabla distribuida.
Causas posibles
Un nodo se detiene o falla durante la expansión de la capacidad.
Procedimiento
- En FusionInsight Manager, elija Cluster > Services > ClickHouse > Instance.
- Compruebe si una instancia está detenida, fuera de servicio o defectuosa.
- Inicie la instancia o rectifique el error de instancia hasta que todas las instancias se ejecuten correctamente.
- En FusionInsight Manager, elija O&M > Alarm > Alarms, localice esta alarma y el host defectuoso basado en la información de ubicación.
- Inicie sesión en el host defectuoso como usuario omm.
- Ejecute los siguientes comandos para inicializar variables de entorno:
source Cluster installation directory/FusionInsight_ClickHouse_*/*_*_ClickHouseServer/etc/ENV_VARS
source Cluster installation directory/FusionInsight_ClickHouse_*/*_*_ClickHouseServer/etc/clickhouse-env.sh
export CLICKHOUSE_CONF_DIR=${CLICKHOUSE_CONF_DIR}
- Ejecute el siguiente comando para ejecutar la herramienta de sincronización de metadatos para sincronizar metadatos desde el nodo existente al nodo defectuoso:
sh Cluster installation directory/FusionInsight_ClickHouse_*/install/FusionInsight-ClickHouse-*/clickhouse/sbin/clickhouse-create-meta.sh true
- Ejecute el siguiente comando para ver la información del registro y comprobar si los metadatos se han sincronizado:
- En FusionInsight Manager, seleccione O&M > Alarm > Alarms. En la columna Alarm ID, localice la alarma correspondiente y haga clic en Clear en la columna Operation. En el cuadro de diálogo que se muestra, haga clic en OK para borrar manualmente la alarma.
Recopilar información de fallas.
- En FusionInsight Manager, seleccione O&M. En el panel de navegación de la izquierda, elija Log > Download.
- Expanda la lista desplegable Service, seleccione ClickHouse para el clúster de destino y haga clic en OK.
- Elija el host correspondiente de la lista de hosts.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 30 minutos antes y después del tiempo de generación de alarmas respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con y proporcione los registros recopilados.
Eliminación de alarmas
Esta alarma necesita ser borrada manualmente después de que se corrija la falla.
Información relacionada
Ninguna