Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Centro de ayuda/ MapReduce Service/ Guía del usuario/ Referencia de alarma (aplicable a MRS 3.x)/ ALM-43009 Tiempo de GC de proceso de JobHistory2x excede el umbral
Actualización más reciente 2023-11-20 GMT+08:00

ALM-43009 Tiempo de GC de proceso de JobHistory2x excede el umbral

Descripción

El sistema comprueba el tiempo de recolección de basura (GC) del proceso JobHistory2x cada 60 segundos. Esta alarma se genera cuando el tiempo GC detectado excede el umbral (excede 5 segundos durante tres comprobaciones consecutivas). Para cambiar el umbral, elija O&M > Alarm > Thresholds > Name of the desired cluster > Spark2x > GC Time > Total GC time in milliseconds (JobHistory2x). Esta alarma se borra cuando el tiempo de JobHistory2x GC es menor o igual que el umbral.

Atributo

ID de alarma

Gravedad de la alarma

Borrar automáticamente

43009

Importante

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el nombre del servicio para el que se genera la alarma.

RoleName

Especifica el nombre del rol para el que se genera la alarma.

HostName

Especifica el objeto (ID de host) para el que se genera la alarma.

Trigger Condition

Especifica el umbral que activa la alarma. Si el valor del indicador actual excede este umbral, se genera la alarma.

Impacto en el sistema

Si el tiempo de GC excede el umbral, JobHistory2x puede ejecutarse con bajo rendimiento.

Causas posibles

La memoria de JobHistory2x se utiliza en exceso, la memoria heap se asigna de forma inapropiada. Como resultado, los GC ocurren con frecuencia.

Procedimiento

Comprobar el tiempo de GC.

  1. En el portal del Administrador FusionInsight, seleccione O&M > Alarm > Alarms y seleccione la alarma cuyo ID es 43009. Compruebe el RoleName en Location y confirme la dirección IP de HostName.
  2. En el portal del Administrador FusionInsight, elija Cluster > Name of the desired cluster > Services > Spark2x > Instance y haga clic en JobHistory2x para el que se genera la alarma para ir a la página Dashboard. Haga clic en el menú desplegable en el área Chart y elija Customize > GC Time > Garbage Collection (GC) Time of JobHistory2x en el cuadro de lista desplegable en la esquina superior derecha y haga clic en OK para comprobar si el tiempo de GC es más largo que el umbral (valor predeterminado: 12 segundos).

    • En caso afirmativo, vaya a 3.
    • Si no, vaya a 6.
    Figura 1 Tiempo de Recolección de basura (GC) de JobHistory2x

  3. En el portal de FusionInsight Manager, elija Cluster > Name of the desired cluster > Services > Spark2x > Configurations y haga clic en All Configurations. Elija JobHistory2x > Default. El valor predeterminado de SPARK_DAEMON_MEMORY es 4 GB. Puede cambiar el valor de acuerdo con las siguientes reglas: Si esta alarma se genera ocasionalmente, aumente el valor en 0.5 veces. Si la alarma se informa con frecuencia, aumente el valor en 1 vez.
  4. Reinicie todas las instancias de JobHistory2x.
  5. Después de 10 minutos, compruebe si la alarma está borrada.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 6.

Recopilar información de fallas.

  1. En la interfaz del FusionInsight Manager de los clústeres activos y en espera, seleccione O&M > Log > Download.
  2. Seleccione Spark2x en el clúster requerido en el Service.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

Información relacionada

Ninguna