ALM-23003 Error de ejecución de tareas del Loader
Descripción
Esta alarma se genera inmediatamente cuando el sistema detecta que el trabajo del Loader falla. Esta alarma se borra cuando el trabajo fallido es manejado manualmente por un usuario. Esta alarma debe borrarse manualmente.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrado automáticamente |
---|---|---|
23003 |
Leves |
No |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
JobID |
Especifica el ID del trabajo de Loader fallido. |
JobName |
Especifica el trabajo de cargador fallido. |
UserName |
Especifica el nombre del usuario que envía el trabajo Loader. |
Details |
Información complementaria para la que se genera la alarma. |
Impacto en el sistema
Se produce una excepción durante la ejecución del trabajo de cargador enviado y la ejecución falla. No se puede obtener ningún resultado de ejecución. Ejecute el trabajo de nuevo después de rectificar la falla.
Causas posibles
- Los parámetros de tarea están configurados incorrectamente.
- Las excepciones se producen cuando Yarn está ejecutando un trabajo.
Procedimiento
Comprobar si los parámetros de la tarea están configurados incorrectamente.
- En el FusionInsight Manager, seleccione O&M > Alarm > Alarms y haga clic en la lista desplegable de alarmas de la lista de alarmas, obtenga la Alarm Cause.
- Si la causa de la alarma es "Failure to send job", vea los detalles del error de Información adicional y vaya al Loader WebUI para ver el historial de ejecución del trabajo.
De forma predeterminada, el usuario admin no tiene los permisos para gestionar otros componentes. Si la página no se puede abrir o el contenido mostrado está incompleto al acceder a la interfaz de usuario nativa de un componente debido a la falta de permisos, puede crear manualmente un usuario con los permisos para gestionar ese componente.
- Vuelva a enviar la tarea.
- Compruebe si la tarea se ejecutó correctamente.
Comprobar si se producen excepciones cuando Yarn está ejecutando un trabajo.
- En FusionInsight Manager, haga clic en la lista desplegable de alarmas de la lista de alarmas y obtenga el Alarm Cause.
- Compruebe si la actividad de Yarn se ejecuta correctamente en el Alarm Cause. Si la causa de la alarma es "Yarn execution failed", la actividad de Yarn es anormal.
- Vuelva a enviar la tarea.
- Compruebe si la tarea se ejecutó correctamente.
- En la lista de alarmas, haga clic en Clear de Operation para borrar manualmente la alarma. No se requiere ninguna otra acción.
Recopilar información de fallas.
- En FusionInsight Manager, elija O&M > Log > Download.
- Seleccione los siguientes nodos en el clúster requerido en la lista desplegable Service:
- DBService
- HDFS
- Loader
- Mapreduce
- Yarn
- ZooKeeper
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe los registros recopilados.
Eliminación de alarmas
Después de rectificar la falla, el sistema no borra automáticamente esta alarma, y es necesario borrar manualmente la alarma.
Información relacionada
Ninguna