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Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-19018 El tamaño de la cola de compactación de HBase supera el umbral
Actualización más reciente 2023-11-20 GMT+08:00

ALM-19018 El tamaño de la cola de compactación de HBase supera el umbral

Descripción

El sistema comprueba el tamaño de la cola de compactación de HBase cada 300 segundos. Esta alarma se genera cuando el tamaño de la cola de compactación supera el umbral de alarma (100 por defecto). Esta alarma se borra cuando el tamaño de la cola de compactación es menor que el umbral.

Atributo

ID de alarma

Gravedad de la alarma

Borrar automáticamente

19018

Leves

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

El rendimiento del clúster puede deteriorarse, lo que afecta a la lectura y escritura de datos.

Causas posibles

  • El número de RegionServers de HBase es demasiado pequeño.
  • Hay regiones excesivas en un solo RegionServer de HBase.
  • El tamaño de heap de RegionServer de HBase es pequeño.
  • Los recursos son insuficientes.
  • Los parámetros relacionados no están configurados correctamente.

Procedimiento

Comprobar si los parámetros relacionados están configurados correctamente.

  1. Inicie sesión en FusionInsight Manager y elija O&M > Alarm > Alarms. En la página que se muestra, compruebe si existe la alarma cuyo Alarm ID sea 19008 o 19011.

    • En caso afirmativo, haga clic en View Help junto a la alarma y rectifique la falla consultando el documento de ayuda. A continuación, vaya a 3.
    • Si no, vaya a 2.

  2. En FusionInsight Manager, elija Cluster > Name of the desired cluster > Services > HBase. En la página que se muestra, haga clic en la pestaña Configuration y luego en la subpestaña All Configurations, busque hbase.hstore.compaction.min, hbase.hstore.compaction.max, hbase.regionserver.thread.compaction.small, y hbase.regionserver.thread.compaction.throttle, y los establezca en valores más grandes.
  3. Verifique si la alarma se ha borrado.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 4.

Recopilar información de fallas.

  1. En FusionInsight Manager, seleccione O&M. En el panel de navegación de la izquierda, elija Log > Download.
  2. Expanda la lista desplegable Service y seleccione HBase para el clúster de destino.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con y proporcione los registros recopilados.

Eliminación de alarmas

Esta alarma se borra automáticamente después de rectificar la falla.

Información relacionada

Ninguna