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Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-19012 Directorio de tabla de sistema de HBase o archivo perdido
Actualización más reciente 2023-11-20 GMT+08:00

ALM-19012 Directorio de tabla de sistema de HBase o archivo perdido

Descripción

El sistema comprueba si existen directorios y archivos de HBase en el HDFS cada 120 segundos. Esta alarma se genera cuando el sistema detecta que los archivos o directorios no existen. Esta alarma se borra cuando se restauran los archivos o directorios.

Los directorios y archivos de HBase son los siguientes:

  • Directorio del espacio de nombres hbase en HDFS
  • Archivo hbase.version
  • Directorio de la tabla hbase:meta en el archivo HDFS, .tableinfo y .regioninfo
  • Directorio de la tabla hbase:namespace en el archivo HDFS, .tableinfo y .regioninfo
  • Directorio de la tabla hbase:hindex en el archivo HDFS, .tableinfo y .regioninfo
  • Directorio de la tabla hbase:acl en el archivo HDFS, .tableinfo y .regioninfo (Esta tabla no existe en el clúster de modo común de forma predeterminada.)

Atributo

ID de alarma

Gravedad de la alarma

Borrado automáticamente

19012

Crítica

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

El servicio HBase no puede reiniciarse o iniciarse.

Causas posibles

Faltan archivos o directorios en el HDFS.

Procedimiento

Localizar la causa de la alarma.

  1. En el FusionInsight Manager, seleccione O&M > Alarm > Alarms. Haga clic en esta alarma y compruebe si Alarm Cause indica errores desconocidos.

    • En caso afirmativo, vaya a 4.
    • Si no, vaya a 2

  2. En la página de inicio del FusionInsight Manager, seleccione O&M > Backup and Restoration > Backup Management. Compruebe si hay registros de éxito de la tarea de copia de respaldo llamada default u otras tareas de copia de respaldo de metadatos de HBase que se han ejecutado correctamente.

    • En caso afirmativo, vaya a 3.
    • Si no, vaya a 4.

  3. Utilice los metadatos de copia de respaldo más recientes para restaurar los metadatos del servicio HBase.

Recopilar información de fallas.

  1. En la página FusionInsight Manager de los clústeres activo y en espera, seleccione O&M > Log > Download.
  2. En el área Service, seleccione los servicios HBase defectuosos en el clúster requerido.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

Información relacionada

Ninguna