Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-18023 El número de tareas pendientes de Yarn supera el umbral
Actualización más reciente 2023-11-20 GMT+08:00

ALM-18023 El número de tareas pendientes de Yarn supera el umbral

Descripción

El módulo de alarma comprueba el número de aplicaciones pendientes en la cola root de Yarn cada 60 segundos. La alarma se genera cuando el número excede de 60.

Atributo

ID de alarma

Gravedad de la alarma

Borrar automáticamente

18023

Importante

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

QueueName

Identifica la cola para la que se genera la alarma.

QueueMetric

Identifica el indicador de cola para el que se genera la alarma.

Impacto en el sistema

  • Se necesita mucho tiempo para finalizar una solicitud.
  • Una nueva aplicación no se puede ejecutar después del envío.

Causas posibles

  • Los recursos del nodo de NodeManager son insuficientes.
  • La capacidad máxima de recursos de la cola y el porcentaje máximo de recursos de AM son demasiado pequeños.
  • El umbral de supervisión es demasiado pequeño.

Procedimiento

Comprobar los recursos de NodeManager.

  1. En FusionInsight Manager, elija Cluster > Name of the desired cluster > Services > Yarn > ResourceManager (Active) para acceder a la interfaz de usuario web de ResourceManager.
  2. Haga clic en Scheduler y compruebe si los recursos de cola raíz se utilizan en Application Queues.

    • En caso afirmativo, vaya a 3.
    • Si no, vaya a 4.

  3. Amplíe la capacidad de la instancia NodeManager del servicio Yarn. Después de la ampliación de la capacidad, compruebe si la alarma está desactivada.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 6.

Comprobar la capacidad máxima de recursos de la cola y el porcentaje máximo de recursos de AM.

  1. Compruebe si los recursos de la cola correspondientes a la tarea pendiente están agotados.

    • En caso afirmativo, vaya a 5.
    • Si no, vaya a 6.

  2. En FusionInsight Manager, elija Tenant Resources > Dynamic Resource Plan y agregue recursos según sea necesario. Compruebe si las alarmas están desactivadas.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 6.

Ajustar los umbrales de monitoreo.

  1. En FusionInsight Manager, elija O&M > Alarm > Thresholds > Name of the desired cluster > Yarn > Applications > Pending Applications, y aumente los umbrales según sea necesario.
  2. Compruebe si la alarma se borra 5 minutos más tarde.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 8.

Recopilar información de fallas.

  1. En FusionInsight Manager, seleccione O&M. En el panel de navegación de la izquierda, elija Log > Download.
  2. Expanda la lista desplegable Service y seleccione Yarn para el clúster de destino.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con y proporcione los registros recopilados.

Eliminación de alarmas

Esta alarma se borra automáticamente después de rectificar la falla.

Información relacionada

Ninguna