Help Center/ MapReduce Service/ User Guide/ MRS Cluster O&M/ MRS Cluster Alarm Handling Reference/ ALM-17009 Abnormal Connection Between Oozie and DBService
Updated on 2024-09-23 GMT+08:00

ALM-17009 Abnormal Connection Between Oozie and DBService

Alarm Description

Oozie depends on DBService. After a task is submitted, the system checks DBService connectivity. This alarm is generated when the service fails the check for 10 consecutive times.

This alarm is cleared when the connection between Oozie and DBService becomes normal.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

17009

Minor

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Trigger Condition

Specifies the threshold for triggering the alarm.

Impact on the System

Running scheduling tasks are blocked and new scheduling tasks cannot be submitted.

Possible Causes

  • The DBService service is abnormal.
  • Oozie fails to connect to DBService.

Handling Procedure

Check the DBService status.

  1. In the service list on FusionInsight Manager, check whether Running Status of DBService is Normal.

    • If yes, go to 5.
    • If no, go to 2.

  2. In the alarm list, check whether ALM-27001 DBService Service Unavailable is reported.

    • If yes, go to 3.
    • If no, go to 5.

  3. Rectify the fault by performing the operations provided for ALM-27001 DBService Service Unavailable.
  4. Wait for several minutes and check whether the alarm Abnormal Connection Between Oozie and DBService is cleared.

    • If yes, no further action is required.
    • If no, go to 5.

Check the connectivity between Oozie and DBService.

  1. Log in to FusionInsight Manager, choose O&M > Log > Online Search, select the Oozie service, and search for the keyword [Oozie Alarm Enhancement][DB Service] in the log. View the cause in the log, and rectify the fault. In the alarm list, check whether the alarm Abnormal Connection Between Oozie and DBService is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Select Oozie for Service and click OK.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.