Help Center/ MapReduce Service/ User Guide/ MRS Cluster O&M/ MRS Cluster Alarm Handling Reference/ ALM-16055 Hive Failed to Access the Data Warehouse Directory
Updated on 2026-09-24 GMT+08:00

ALM-16055 Hive Failed to Access the Data Warehouse Directory

Alarm Description

The Hive service checks whether the Hive data warehouse directory can be accessed properly at startup and periodically every 60 seconds after startup. If the directory cannot be accessed, this alarm is reported.

When the Hive service can access the Hive data warehouse directory at startup and every 60 seconds after startup, this alarm is cleared.

This section applies only to MRS 3.6.0-LTS or later.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

16055

Critical

Quality of service

Hive

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

The system cannot provide data loading, query, and extraction functions.

Possible Causes

  • The HDFS service is abnormal.
  • OBS is abnormal.

Handling Procedure

  1. Log in to FusionInsight Manager, and choose O&M > Alarm > Alarms.
  2. Click the alarm name to expand the details and check Alarm Cause to obtain the cause of the alarm.

    • If HDFS abnormal is displayed, go to Step 3.
    • If Failed to access OBS. Check whether the OBS connection is normal. is displayed, go to Step 6.

  1. In the alarm list, check whether there is an HDFS Service Unavailable alarm.

  2. Rectify the fault by performing the operations provided for ALM-14000 HDFS Service Unavailable.
  3. In the alarm list, check whether the HDFS Service Unavailable and Hive Failed to Access the Data Warehouse Directory alarms are cleared.

    • If yes, no further action is required.
    • If no, go to Step 6.

  1. Contact O&M personnel of OBS to rectify the OBS fault.
  2. Check whether the alarm is cleared in the alarm list.

    • If yes, no further action is required.
    • If no, go to Step 8.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, select HDFS and Hive for the target cluster, and click OK.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.