Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-16048 Ruta de biblioteca de Tez o Spark no existe
Actualización más reciente 2023-11-20 GMT+08:00

ALM-16048 Ruta de biblioteca de Tez o Spark no existe

Descripción

El sistema comprueba las rutas de las bibliotecas Tez y Spark cada 180 segundos. Esta alarma se genera cuando la ruta de la biblioteca Tez o Spark no existe.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

16048

Grave

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Las funciones de Hive on Tez y Hive on Spark se ven afectadas.

Causas posibles

La ruta de acceso de la biblioteca Tez o Spark se elimina del HDFS.

Procedimiento

Comprobar el almacén de datos predeterminado de Hive.

  1. Inicie sesión en el nodo donde se encuentra el cliente como usuario root.
  2. Ejecute el siguiente comando para comprobar si el directorio tezlib o sparklib existe en el director hdfs://hacluster/user/{User name}/.Trash/Current/:

    hdfs dfs -ls hdfs://hacluster/user/<username>/.Trash/Current/

    Por ejemplo, la siguiente información muestra que /user/hive/tezlib// y /user/hive/sparklib// existen.

    host01 # hdfs dfs -ls hdfs://hacluster/user/test/.Trash/Current/ 
    Found 1 items 
    drwx------   - test hadoop          0 2019-06-17 19:53 hdfs://hacluster/user/test/.Trash/Current/user
    • En caso afirmativo, vaya a 3.
    • Si no, vaya a 5.

  3. Ejecute el siguiente comando para restaurar tezlib y sparklib.

    hdfs dfs -mv hdfs://hacluster/user/<username>/.Trash/Current/user/hive/tezlib//tez.tar.gz /user/hive/tezlib//tez.tar.gz

  4. Verifique si la alarma se ha borrado.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 5.

    Recopilar información de fallas.

  5. Recopile información relacionada en el directorio .Trash/Current/ en el fondo del cliente.
  6. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

Información relacionada

Ninguna