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Actualización más reciente 2023-11-20 GMT+08:00

ALM-13007 Las conexiones de cliente de ZooKeeper disponibles son insuficientes

Descripción

El sistema detecta periódicamente el número de procesos activos entre el cliente de ZooKeeper y el servidor de ZooKeeper cada 60 segundos. Esta alarma se genera cuando el número de conexiones excede el umbral.

Atributo

ID de alarma

Gravedad de la alarma

Borrado automáticamente

13007

Leves

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el nombre del servicio para el que se genera la alarma.

RoleName

Especifica el nombre del rol para el que se genera la alarma.

HostName

Especifica el nombre de host para el que se genera la alarma.

ClientIP

Especifica la dirección IP del cliente.

ServerIP

Especifica la dirección IP del servidor.

Trigger Condition

Especifica la causa de la alarma.

Impacto en el sistema

Un gran número de conexiones a ZooKeeper hizo que el ZooKeeper estuviera completamente conectado y no pudiera proporcionar servicios normales.

Causas posibles

Un gran número de procesos de cliente están conectados a ZooKeeper. Los umbrales no son apropiados.

Procedimiento

Compruebe si hay una gran cantidad de procesos de clientes conectados a ZooKeeper.

  1. En FusionInsight Manager, seleccione O&M > Alarm > Alarms. En la interfaz mostrada, haga clic en el botón desplegable de Available ZooKeeper Client Connections Are Insufficient. Confirme la dirección IP del nodo del host para el que se genera la alarma en la información de ubicación.
  2. Abra la interfaz del servicio de ZooKeeper, haga clic en Resource para entrar en la página Resource y compruebe si el número de conexiones del cliente con la dirección IP especificada por Number of Connections (By Client IP Address) es grande.

    • Si lo es, vaya a 3.
    • Si no es así, vaya a 4.

  3. Compruebe si se produce una fuga de conexión en el proceso del cliente.
  4. Haga clic en en el Number of Connections (by Client IP Address) para entrar en la página Thresholds y haga clic en Modify en Operation. Aumente el umbral haciendo referencia al valor de maxClientCnxns seleccionando Cluster > Name of the desired cluster > Services > ZooKeeper > Configurations > All Configurations > quorumpeer.
  5. Verifique si la alarma se ha borrado.

    • Si lo es, no se requiere ninguna otra acción.
    • Si no es así, vaya a 6.

Recopilar información de fallas.

  1. En el portal del FusionInsight Manager, elija O&M > Log > Download.
  2. Seleccione ZooKeeper en el clúster requerido en el Service.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

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Ninguna