ALM-12027 El uso de PID de host supera el umbral
Descripción
El sistema comprueba el uso del PID cada 30 segundos y compara el uso real del PID con el umbral de uso predeterminado del PID. Esta alarma se genera cuando el sistema detecta que el uso de PID excede el umbral.
Cuando el Trigger Count es 1, esta alarma se borra cuando el uso de PID es menor o igual que el umbral. Cuando el Trigger Count es mayor que 1, esta alarma se borra cuando el uso de PID es menor o igual al 90% del umbral.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrar automáticamente |
---|---|---|
12027 |
Importante |
Sí |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster o sistema para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Trigger Condition |
Especifica el umbral que activa la alarma. Si el valor del indicador actual excede este umbral, se genera la alarma. |
Impacto en el sistema
No hay ningún PID disponible para los nuevos procesos y los procesos de servicio no están disponibles.
Causas posibles
Se están ejecutando demasiados procesos en el nodo. Necesita aumentar el valor de pid_max.
Procedimiento
Aumentar el valor de pid_max.
- En la lista de alarmas del FusionInsight Manager, haga clic en en la fila donde se encuentra la alarma para ver la dirección del host de alarma en los detalles de la alarma.
- Inicie sesión en el host donde se genera la alarma como usuario root.
- Ejecute el comando cat /proc/sys/kernel/pid_max para comprobar el valor de pid_max.
- Si el uso de PID excede el umbral, ejecute el comando echo new value > /proc/sys/kernel/pid_max para ampliar el valor de pid_max.
Ejemplo: echo 65536 > /proc/sys/kernel/pid_max
El valor máximo de pid_max es el siguiente:
- On 32-bit systems: 32768
- On 64-bit systems: 4194304 (2^22)
- Espere 5 minutos y compruebe si la alarma está desactivada.
- De ser así, no se requiere ninguna acción adicional.
- Si no, vaya a 6.
Recopilar información de fallas.
- En la página principal del FusionInsight Manager del clúster activo, elija O&M > Log > Download.
- Seleccione todos los servicios en el Service y haga clic en OK.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 30 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe la información de registro recopilada.
Eliminación de alarmas
Después de rectificar la falla, el sistema borra automáticamente esta alarma.
Información relacionada
Ninguna