ALM-12014 Partición perdida
Descripción
El sistema comprueba el estado de la partición cada 60 segundos. Esta alarma se genera cuando el sistema detecta que se ha perdido una partición en la que se montan los directorios de servicio (porque el dispositivo se quita o se desconecta, o la partición se elimina). El sistema comprueba periódicamente el estado de la partición.
Esta alarma debe borrarse manualmente.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrar automáticamente |
---|---|---|
12014 |
Importante |
No |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster o sistema para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
DirName |
Especifica el directorio para el que se genera la alarma. |
PartitionName |
Especifica la partición de dispositivo para la que se genera la alarma. |
Impacto en el sistema
Los datos de servicio no se pueden escribir en la partición y el sistema de servicio se ejecuta de forma anormal.
Causas posibles
- Se quita el disco duro.
- El disco duro está fuera de línea o existe un sector defectuoso en el disco duro.
Procedimiento
- En FusionInsight Manager, haga clic en O&M > Alarm > Alarms y haga clic en en la fila donde se encuentra la alarma.
- Obtenga HostName, PartitionName y DirName a partir de Location.
- Compruebe si el disco de PartitionName de HostName está insertado en la ranura del servidor correcta.
- Póngase en contacto con los ingenieros de hardware para quitar el disco defectuoso.
- Inicie sesión en el nodo HostName donde se notifica una alarma y compruebe si hay una línea que contiene DirName en el archivo /etc/fstab como usuario root.
- Ejecute el comando vi /etc/fstab para editar el archivo y eliminar la línea que contiene DirName.
- Póngase en contacto con los ingenieros de hardware para insertar un nuevo disco. Para obtener más información, consulte el documento del producto de hardware del modelo correspondiente. Si el disco defectuoso está en un grupo RAID, configure el grupo RAID. Para obtener más información, consulte los métodos de configuración de la tarjeta controladora de RAID relevante.
- Espere de 20 a 30 minutos (el tamaño del disco determina el tiempo de espera) y ejecute el comando mount para comprobar si el disco se ha montado en el directorio DirName.
- En caso afirmativo, borre la alarma manualmente. No se requiere ninguna operación adicional.
- Si no, vaya a 9.
Recopilar información de fallas.
- En el FusionInsight Manager, elija O&M > Log > Download.
- Seleccione el OmmServer en la lista desplegable Servicios y haga clic en OK.
- Establezca Start Date para la recopilación de registros en 10 minutos antes de la hora de generación de alarmas y End Date en 10 minutos antes de la hora de generación de alarmas y haga clic en Download.
- Póngase en contacto con el y envíe la información de registro recopilada.
Eliminación de alarmas
Después de rectificar la falla, el sistema no borra automáticamente esta alarma, y es necesario borrar manualmente la alarma.
Información relacionada
Ninguna