Help Center/ SAP Cloud/ SAP HANA User Guide (Single Node)/ FAQs/ What Should I Do If I Cannot Switch to an ECS or HANA ECS Using SSH?
Updated on 2022-03-04 GMT+08:00

What Should I Do If I Cannot Switch to an ECS or HANA ECS Using SSH?

Symptom

When I switched from a Linux ECS/HANA ECS to another Linux ECS/HANA ECS using SSH, the system displayed a message indicating the switching failed.

The message is as follows:

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
2c:d0:17:8a:82:4c:23:d6:14:be:d0:1d:88:8b:8b:03 [MD5].
Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /root/.ssh/known_hosts:1
You can use following command to remove all keys for this IP:
ssh-keygen -R fanhana-0002 -f /root/.ssh/known_hosts
RSA host key for fanhana-0002 has changed and you have requested strict checking.
Host key verification failed.

Possible Causes

  • OpenSSH has been reinstalled on the target ECS/HANA ECS.
  • The node IP address or name has been changed.
  • Other issues have occurred.

Handling Method

Delete the known_hosts file on the local end to resolve this issue. To do so, perform the following operations:

  1. On the local ECS/HANA ECS, switch to the CLI as user root.
  2. Run the following command to delete the known_hosts file:

    rm /root/.ssh/known_hosts

    After the file deletion, when you attempt to switch to the target ECS/HANA ECS using SSH, the system displays the fingerprint as well as the message "Are you sure you want to continue connecting (yes/no)?". In such a case, enter yes and continue the switching.