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Container Health Check Fails When a Service Is Deployed, Started, Upgraded, or Modified
Updated on 2025-08-22 GMT+08:00
Container Health Check Fails When a Service Is Deployed, Started, Upgraded, or Modified
Symptom
The container health check fails during service deployment, startup, upgrade, or modification.
Possible Causes
Calling the container health check API failed. The possible causes are as follows:
- The health check is incorrectly configured for the image.
- The health check is incorrectly configured for the model.
Solution
Check container logs for the cause of the health check failure.
- If the health check is incorrectly configured for the image, debug the code, create an image again and then the model, and use the new model to deploy the service. For details about how to configure the image health API for an image, see parameter health in Specifications for Editing a Model Configuration File.
- If the health check is incorrectly configured for the model, create a new model or create a version of the existing model, correctly configure the health check, and use the new model or version to deploy the service. For details about the model health check, see parameter Health Check in Importing a Meta Model from a Container Image.
Parent topic: Service Deployment
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