ALM-46006 Disk Space Usage of the MOTService Data Directory Exceeds the Threshold
Alarm Description
The system checks the disk space usage of the data directory on the active MOTServer node every 30 seconds and compares the actual disk space usage with the threshold. This alarm is generated when the disk space usage of the data directory exceeds the threshold (80% by default) for five consecutive times (5 by default).
- If Trigger Count is 1, this alarm is cleared when the disk space usage of the data directory is less than or equal to the threshold.
- If Trigger Count is greater than 1, this alarm is cleared when the disk space usage of the data directory is less than 90% of the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
46006 |
Major |
Physical resource |
MOTService |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm was generated. |
ServiceName |
Specifies the service for which the alarm was generated. |
|
RoleName |
Specifies the role for which the alarm was generated. |
|
HostName |
Specifies the host for which the alarm was generated. |
|
PartitionName |
Specifies the disk partition for which the alarm was generated. |
|
Additional Information |
Trigger Condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
- If the disk space of the MOTService data directory is insufficient, service processes may be unavailable.
- When the disk space usage of the data directory exceeds 90%, the database enters the read-only mode and ALM-46007 MOTService Database Enters the Read-Only Mode is generated. As a result, service data is lost.
Possible Causes
- The alarm threshold is improperly configured.
- The database data volume is too large or the disk configuration cannot meet service requirements. As a result, the disk usage reaches the upper limit.
Handling Procedure
Check whether the threshold is set properly.
- On FusionInsight Manager, choose O&M > Alarm > Thresholds, click the name of the desired cluster, choose MOTService > Database > MOT Disk Space Usage of the Data Directory (MOTServer), and check whether the alarm threshold is 80%.
If yes, go to 4.
If no, go to 2.
- Change the alarm threshold based on the actual usage, and apply the change.
- Wait 2 minutes and check whether the alarm is automatically cleared.
If yes, no further action is required.
If no, go to 4.
Check whether large files are incorrectly written to the disk.
- Log in to the active MOTService node as user omm.
- Run the following commands to check whether files with more than 500 MB are incorrectly written into the disk space of the data directory:
source $MOTSERVER_HOME/.motservice_profile
find "$MOTSERVICE_DATA_DIR"/../ -type f -size +500M
If yes, go to 6.
If no, go to 7.
- Handle the incorrectly written files and check whether the alarm is cleared 2 minutes later.
If yes, no further action is required.
If no, go to 7.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list and select MOTService.
- Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the hosts to which the role belongs.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M personnel/Technical support and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None
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