Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-45596 Procedure Execution Failed
Updated on 2024-11-29 GMT+08:00

ALM-45596 Procedure Execution Failed

Alarm Description

Procedures are the tasks managed and executed by the ConfigNode leader. This alarm is generated when a procedure fails to be executed. This alarm is cleared when the procedure is successfully executed.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

45596

Major

Error handling

IoTDB

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Additional Information

ProcedureInformation

Specifies the procedure-related information.

Impact on the System

Functions associated with the procedure are adversely affected.

Possible Causes

  • The task for adding IoTDB replicas fails to be executed.
  • The task for deleting the storage group fails to be executed.

Handling Procedure

  1. On FusionInsight Manager, choose O&M > Alarm > Alarms, locate this alarm, and click .
  2. Check the value of ProcedureInformation in Location. The value starts with the procedure type and contains main information about the procedure.

Check whether the task for adding replicas fails.

  1. Check whether the value of ProcedureInformation starts with AddRegionProcedure or ReJoinDataNodeProcedure.

    • If yes, the task fails. Go to 4.
    • If no, go to 5.

  2. Wait for half an hour. If the region is successfully added, the alarm is automatically cleared. Otherwise, go to 5.

Check whether the task for deleting the storage group fails.

  1. Check whether the value of ProcedureInformation starts with DeleteStorageGroupProcedure.

    • If yes, the storage group fails to be deleted. Go to 6.
    • If no, go to 7.

  2. Delete the storage group displayed in ProcedureInformation again on the IoTDB client. If the deletion is successful, the alarm is automatically cleared. Otherwise, go to 7.

Collect fault information.

  1. Choose Cluster > Services > IoTDB > Instance to view the hosts where all IoTDBServer and ConfigNode instances are located.
  2. Choose O&M > Log > Download.
  3. Expand the Service drop-down list, select IoTDB for the target cluster, and click OK.
  4. Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the host queried in 7, and click OK.
  5. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  6. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.