ALM-45434 A Single Replica Exists in the ClickHouse Data Table
This section applies only to MRS 3.2.1 or later.
Alarm Description
This alarm is generated when a single replica is detected in a custom logical cluster after the custom logical cluster is enabled for ClickHouse.
This alarm is automatically cleared when the system detects that the custom logical cluster uses multiple replicas.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
45434 |
Major |
Quality of service |
ClickHouse |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
If a hardware fault occurs, data cannot be restored.
Possible Causes
The metrika.xml file in the ClickHouse configuration directory contains single-replica configuration.
Handling Procedure
Check whether the configuration in metrika.xml of the ClickHouse instance is correct.
- In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and click to view the name of the host for which the alarm is generated. On the Hosts page, view the host IP address based on the host name.
- Log in to the host where the ClickHouse instance is abnormal, go to the configuration directory of the ClickHouse instance, and run the following commands:
cd ${BIGDATA_HOME}/FusionInsight_ClickHouse_Version/x_x_ClickHouseServer/etc
cat metrika.xml
- View the number of shards in each custom logical cluster and check that a single replica exists. Then, go to 4.
If a shard contains only one node, a single replica exists in a logical cluster, as shown in the following:
<shard> <internal_replication>true</internal_replication> <replica> <host>host-name1</host> <port>port</port> <user>clickhouse</user> <password/> </replica> </shard>
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select ClickHouse for the target cluster.
- Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the abnormal host, and click OK.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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