ALM-45191 Failed to Obtain ECS Metadata
Alarm Description
Before calling an ECS API to obtain the AK/SK information for the first time, Meta calls an ECS API first to obtain and cache the metadata. Then, it updates the cache every day. This alarm is generated when an API fails to be called for three consecutive times.
This alarm is cleared when Meta successfully calls the ECS API to obtain metadata.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
45191 |
Major |
Error handling |
meta |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
For systems with decoupled storage and compute, the cluster cannot obtain the latest temporary AK/SK because it fails to obtain the metadata. As a result, the cluster fails to access OBS, and component services cannot be provided.
Possible Causes
- The meta role of the MRS cluster is abnormal.
- The cluster has been bound to an agency and accessed OBS, but it has been unbound from the agency currently.
Handling Procedure
Check the status of the meta role.
- On FusionInsight Manager, choose O&M > Alarm > Alarms, click in the row of this alarm, and view the host name of the instance for which the alarm is generated in Location.
- On FusionInsight Manager of the cluster, choose Cluster > Services > meta. On the page that is displayed, click the Instance tab, and check whether the meta role corresponding to the host for which the alarm is generated is normal.
- Select the abnormal role, click More, and select Restart Instance to restart the abnormal meta role.
- Check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 5.
- Log in to the host obtained in 1 and check whether the /var/log/Bigdata/meta/mrs-meta.log file contains error information. If yes, rectify the fault based on the log information.
- Check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 7.
Rebind the cluster to an agency.
- Log in to the MRS console.
- In the navigation pane on the left, choose Clusters > Active Clusters. On the page that is displayed, click the cluster name to go to its dashboard. Then, check whether the cluster is bound to an agency in the O&M management area.
- Click Manage Agency. On the page that is displayed, rebind the cluster to an agency. Then check whether the alarm is cleared a few minutes later.
- If yes, no further action is required.
- If no, go to 10.
Collect fault information.
- On FusionInsight Manager of the active cluster, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, select meta for the target cluster, and click OK.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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