ALM-25000 LdapServer Service Unavailable
Alarm Description
The system checks the LdapServer service status every 30 seconds. This alarm is generated when the system detects that both the active and standby LdapServer services are abnormal.
This alarm is cleared when the system detects that one or two LdapServer services are normal.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
25000 |
Critical |
Quality of service |
FusionInsight Manager |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
The running status of the component that depends on the LdapServer becomes faulty. As a result, Kerberos authentication fails in the cluster or OS user cache synchronization is abnormal, and component services are abnormal.
Possible Causes
- The node where the LdapServer service locates is faulty.
- The LdapServer process is abnormal.
Handling Procedure
Check whether the nodes where the two SlapdServer instances of the LdapServer service are located are faulty.
- On FusionInsight Manager, choose Cluster > Name of the desired cluster > Services > LdapServer > Instance to go to the LdapServer instance page to obtain the host name of the node where the two SlapdServer instances locates.
- Choose O&M > Alarm > Alarms. On the Alarm page of the FusionInsight Manager system, check whether any alarm of NodeAgent Process Is Abnormal exists.
- Check whether the host name in the alarm is consistent with the 1 host name.
- Handle the alarm according to "ALM-12006 NodeAgent Process Is Abnormal".
- Check whether LdapServer Service Unavailable is cleared in the alarm list.
- If yes, no further action is required.
- If no, go to 10.
Check whether the LdapServer process is normal.
- Choose O&M > Alarm > Alarms. On the Alarm page of the FusionInsight Manager system, check whether any alarm of Process Fault exists.
- Check whether the service and host name in the alarm are consistent with the LdapServer service and host name.
- Handle the alarm according to "ALM-12007 Process Fault".
- Check whether LdapServer Service Unavailable is cleared in the alarm list.
- If yes, no further action is required.
- If no, go to 10.
Collect fault information.
- On the FusionInsight Manager, choose O&M > Log > Download.
- Select LdapServer in the required cluster from the Service.
- Click the edit button in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M engineers and send the collected logs.
Alarm Clearance
After the fault is rectified, the system automatically clears this alarm.
Related Information
None.
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