Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-19031 Number of RegionServer RPC Connections Exceeds the Threshold
Updated on 2024-11-29 GMT+08:00

ALM-19031 Number of RegionServer RPC Connections Exceeds the Threshold

Alarm Description

The system checks the number of RegionServer RPC connections in each HBase service every 30 seconds. This alarm is generated when the number of RPC connections of a RegionServer instance exceeds the threshold for 10 consecutive times.

This alarm is cleared when the number of RPC connections of a RegionServer instance is less than or equal to the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

19031

  • Critical (default threshold: 200)
  • Major (default threshold: 100)

Quality of service

HBase

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Additional Information

Threshold

Specifies the threshold for generating the alarm.

Impact on the System

There are a large amount of concurrent access requests on the RegionServer node, which imposes great pressure and causes slow response. For latency-sensitive services, a large number of service read and write requests may time out.

Possible Causes

Too many concurrent requests are sent from applications to access HBase.

Handling Procedure

  1. Log in to FusionInsight Manager and choose O&M. In the navigation pane on the left, choose Alarm > Alarms. On the page that is displayed, locate the row containing the alarm whose Alarm ID is 19031, and view the service instance and host name in Location.

Check the number of concurrent requests accessing HBase.

  1. Log in to the node where the HBase client is installed and check whether hbase.client.ipc.pool.size in the Client installation directory/HBase/hbase/conf/hbase-site.xml file is set to a large value.

    • If yes, go to 3.
    • If no, go to 5.

  2. Decrease the value of hbase.client.ipc.pool.size and save the change.
  3. Wait several minutes and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 5.

  4. Check whether the number of concurrent requests accessing the HBase service is too large.

    • If yes, go to 6.
    • If no, go to 8.

  1. Decrease the number of concurrent requests based on the site requirements.
  2. Wait several minutes and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 8.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select HBase for the target cluster.
  3. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.