Help Center/ Server Migration Service/ FAQs/ Known Errors and Solutions/ SMS.6533 VSS Not Installed on the Source Server
Updated on 2024-11-29 GMT+08:00

SMS.6533 VSS Not Installed on the Source Server

Symptom

After the Agent was started on a Windows source server, the source server did not pass the migration feasibility check, and the error message "SMS.6533 VSS not installed on the source server" was displayed on the SMS console.

Possible Causes

The possible causes are as follows:

  1. The VSS service is not installed on the source server.
  2. The VSS service is disabled on the source server.

Solution

  1. Open the Task Manager and check whether the VSS service is there.

    If it is, go to 2.

    If it is not, go to 3.
    Figure 1 Checking whether VSS exists
  2. Modify the configuration file to skip snapshot creation.

    Open the \config\g-property.cfg file in the Agent installation directory and change the value of enablesnapshot to False. The migration task will skip snapshot creation.

    Skipping snapshot creation may cause data time difference between the target server and the source server after the migration is complete, and your services may fail to start on the target server. To ensure data consistency, you are advised to pause services running on the source server during off-peak hours and then perform an incremental synchronization.

    Figure 2 Modifying the g-property.cfg file
  3. Check VSS status. If its status is Stopped, right-click the service and choose Open Services from the shortcut menu. Locate and right-click Volume Shadow Copy, and choose Properties from the shortcut menu. On the displayed Volume Shadow Copy Properties window, change the Startup type to Manual. Click OK.
    Figure 3 Changing the startup mode of VSS
  4. Go back to the Task Manager window, locate and right-click VSS, and choose Start from the shortcut menu.
    Figure 4 Starting VSS
  5. Sign in to the SMS console, locate the server record, and in the Operation column, choose More > Delete.

    After the deletion is complete, restart the Agent.