ALM-12068 ACS Resource Is Abnormal
Alarm Description
HA checks the acs resources of Manager every 80 seconds. This alarm is generated when HA detects that the acs resources are abnormal for two consecutive times.
This alarm is cleared when the ACS resource is normal.
Resource Type of ACS is Single-active. Active/standby will be triggered upon resource exceptions. When this alarm is generated, the active/standby switchover is complete and new ACS resources have been enabled on the new active FusionInsight Manager. In this case, this alarm is cleared. This alarm is used to notify users of the cause of the active/standby switchover.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
12068 |
Major |
Yes |
Parameters
Parameter |
Description |
---|---|
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the name of the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
- The active/standby FusionInsight Manager switchover occurs.
- The ACS process repeatedly restarts, which may cause the FusionInsight Manager login failure.
Possible Causes
The ACS process is abnormal.
Procedure
Check whether the ACS process is abnormal.
- In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and view the name of the host for which the alarm is generated.
- Log in to the host for which the alarm is generated as user root.
- Run the su -omm command and then the sh ${BIGDATA_HOME} /om-server/OMS/workspace0/ha/module/hacom/script/status_ha.sh command to check whether the status of the ACS resources managed by the HA is normal. In the single-node system, the ACS resource is in the normal state. In the dual-node system, the ACS resource is in the normal state on the active node and in the stopped state on the standby node.
- Run the vi $BIGDATA_LOG_HOME/omm/oms/ha/scriptlog/acs.log command to view the ACS resource logs, check whether the keyword ERROR exists. Analyze the logs to locate and rectify the fault.
- One hour later, check whether the alarm is cleared.
- If it is, no further action is required.
- If it is not, go to 6.
Collect fault information.
- On FusionInsight Manager, choose O&M > Log > Download.
- Select Controller and OmmServer for Service and click OK.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M personnel and send the collected log information.
Alarm Clearing
After the fault is rectified, the system automatically clears this alarm.
Related Information
None
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