Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Centro de ayuda> MapReduce Service> Preguntas frecuentes> Desarrollo del trabajo> ¿Cómo lo hago si se muestra el mensaje de error "slot request timeout" cuando envío un trabajo de Flink?
Actualización más reciente 2023-11-20 GMT+08:00

¿Cómo lo hago si se muestra el mensaje de error "slot request timeout" cuando envío un trabajo de Flink?

Síntoma

Cuando se envía un job de Flink, JobManager se inicia correctamente. Sin embargo, TaskManager permanece en el estado inicial hasta el tiempo de espera. Se muestra la siguiente información de error:

org.apache.flink.runtime.jobmanager.scheduler.NoResourceAvailableException: Could not allocate the required slot within slot request timeout. Please make sure that the cluster has enough resources

Causas posibles

  1. Los recursos en la cola YARN son insuficientes. Como resultado, TaskManager no puede iniciarse.
  2. Sus archivos JAR entran en conflicto con los del entorno. Puede ejecutar el programa WordCount para determinar si se produce el problema.
  3. Si el clúster está en modo de seguridad, es posible que el certificado SSL de Flink esté configurado incorrectamente o haya caducado.

Solución

  1. Agregar recursos a la cola YARN.
  2. Excluir las dependencias de Flink y Hadoop en sus archivos JAR para que Flink y Hadoop puedan depender solo de los archivos JAR en el entorno.
  3. Volver a configurar el certificado SSL de Flink. Para obtener más información, consulte Uso de Flink desde principio.

Desarrollo del trabajo Preguntas frecuentes

more