Help Center/ MetaStudio/ FAQs/ Image Modeling/ What If H.265 Training Video Submission Fails on Some Browsers?
Updated on 2024-11-28 GMT+08:00

What If H.265 Training Video Submission Fails on Some Browsers?

Symptom

During virtual avatar image modeling, the uploaded training video cannot be played, or a message is displayed during training task submission, indicating that the video resolution is not supported.

Figure 1 Virtual avatar image modeling

Possible Causes

Browsers such as Chrome support hardware decoding of H.265 (HEVC) videos. If your PC does not support such videos, the videos cannot be played on your browser, and parameters such as the video resolution cannot be obtained.

Enter chrome://gpu in the address box of Chrome and search with coding. You can check whether the browser on the PC supports hardware decoding of H.265 (HEVC) videos.

Figure 2 Checking the browser configuration

Run ffmpeg -i Video file name to check whether the video encoding format is H.265 (HEVC).

Figure 3 Checking the video encoding format

You need to install FFmpeg first following these steps:

  • Download FFmpeg at https://github.com/BtbN/FFmpeg-Builds/releases.
  • Decompress the FFmpeg package and add the bin directory to the system environment variables.
  • Run ffmpeg. If the version number is displayed, the installation is successful.

Troubleshooting

H.265 (HEVC) videos can be transcoded to H.264 videos using CapCut or FFmpeg, and then uploaded to the MetaStudio console for image modeling.

Take ffmpeg as an example. Run ffmpeg -i Video file name -c:v libx264 output.mp4, for example, ffmpeg -i .\test.mp4 -c:v libx264 output.mp4.