¿Cómo puedo arreglar un agente anormal?
Su agente es probablemente anormal si está en estado Not installed o Offline. Los estados de agente y su significado son los siguientes:
- Uninstalled: No se ha instalado ningún agente en el servidor o el agente se ha instalado pero no se ha iniciado.
- Offline: La comunicación entre el agente y el servidor es anormal. El agente en el servidor se ha eliminado, o un servidor que no es de Huawei Cloud está desconectado.
- Online: El agente en el servidor se está ejecutando correctamente.
Causas posibles
- La red presenta fallas.
El agente o el centro de protección en la nube es anormal. Por ejemplo, la NIC está defectuosa, la dirección IP cambia o el ancho de banda es bajo.
- El proceso del agente es anormal.
- No se ha actualizado el estado del agente. Después de instalar el agente, la consola tarda unos 2 minutos en actualizar su estado.
Solución
- Solucionar problemas de red (si los hay).
Asegúrese de que las configuraciones salientes del grupo de seguridad de su servidor permiten el acceso al puerto 10180 en el segmento de red 100.125.0.0/16.
Después de que la red se recupere,
- Si el estado del agente es de Online, no se requiere ninguna acción adicional.
- Si el estado del agente es Not installed o Offline, vaya a 2.
- Inicie sesión en el servidor y reinicie el agente. El estado del agente Not installed o Offline indica que el proceso del agente es probablemente anormal.
- Linux
Ejecute el siguiente comando en la CLI como usuario root para reiniciar el agente:
service hostguard restart
Si se muestra la siguiente información, el reinicio se realiza correctamente:root@HSS-Ubuntu32:~#service hostguard restart Stopping Hostguard... Hostguard stopped Hostguard restarting... Hostguard is running
Después de reiniciar el proceso, espere aproximadamente 2 minutos.
- Si el estado del agente es de Online, no se requiere ninguna acción adicional.
- Si el estado del agente sigue siendo Not installed o Offline, desinstale el agente e instálelo de nuevo.
- Linux
Preguntas Frecuentes de Agentes Preguntas frecuentes
- ¿Está el agente en conflicto con cualquier otro software de seguridad?
- ¿Cómo instalo el agente?
- ¿Cómo desinstalo el agente?
- ¿Qué debo hacer si falló la instalación del agente?
- ¿Cómo puedo arreglar un agente anormal?
- ¿Cuál es la ruta de instalación predeterminada del agente?
- ¿Cuántos recursos de CPU y memoria están ocupados por el agente cuando realiza escaneos?
- ¿WTP y HSS usan el mismo agente?
- ¿Cómo puedo ver los servidores donde no se han instalado agentes?
- ¿Qué puedo hacer si el estado del agente sigue "No instalado" después de la instalación?
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