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Actualización más reciente 2023-08-08 GMT+08:00

¿Por qué un par de claves creado con puttygen.exe no se importa en la consola de gestión?

Síntomas

Cuando intenta importar un par de claves que ha creado con puttygen.exe en la consola de gestión, el sistema muestra un mensaje que indica que la importación falló.

Causas posibles

El formato del contenido de clave pública no cumple con los requisitos del sistema.

Si almacena una clave pública haciendo clic en Save public key en PuTTY Key Generator, el formato del contenido de clave pública cambiará. Por lo tanto, no puede importar la clave en la consola de gestión.

Solución

Utilice la clave privada y el PuTTY Key Generator almacenados localmente para restaurar el formato del contenido de la clave pública. A continuación, importe la clave pública a la consola de gestión.

  1. Haga doble clic puttygen.exe para abrir PuTTY Key Generator.
    Figura 1 Generador de claves PuTTY
  2. Haga clic en Load y seleccione la clave privada.

    El sistema carga automáticamente la clave privada y restaura el formato del contenido de la clave pública de PuTTY Key Generator. El contenido del cuadro rojo de Figura 2 es la clave pública cuyo formato cumple con los requisitos del sistema.

    Figura 2 Restaurar el formato del contenido de la clave pública
  3. Copie el contenido de la clave pública en un archivo .txt y guárdelo en un directorio local.
  4. Importe la clave pública a la consola de gestión.
    1. Inicie sesión en la consola de gestión.
    2. Click in the upper left corner and select your region and project.
    3. En Compute, haga clic en Elastic Cloud Server.
    4. En el panel de navegación de la izquierda, elija Key Pair.
    5. En la página de par de claves, haga clic en Import Key Pair.
    6. Copie el contenido de la clave pública en el archivo .txt en Public Key Content y haga clic en OK.