¿Por qué falla el inicio de sesión en mi ECS de Linux con un archivo de clave?
Síntomas
Cuando utiliza el archivo de clave creado durante la creación de su ECS de Linux para iniciar sesión en el ECS, el inicio de sesión falla.
Causas posibles
Las posibles causas varían dependiendo de la imagen utilizada para crear el ECS de Linux.
- Causa 1: La imagen que utilizó para crear el ECS de Linux es una imagen privada, en la que Cloud-Init no está instalado.
- Causa 2: Cloud-Init está instalado en la imagen, pero no obtuvo el par de claves cuando creó el ECS.
Solución
- Si el problema es resultado de la causa 1, proceda de la siguiente manera:
Si ha creado una imagen privada sin instalar Cloud-Init, no puede personalizar la configuración de ECS. Como resultado, puede iniciar sesión en el ECS solo con la contraseña o el par de claves originales de la imagen.
La contraseña o el par de claves de la imagen original es la contraseña o el par de claves de SO que configuró cuando creó la imagen privada.
Si ha olvidado la contraseña de la imagen original o se ha perdido el par de claves, restablezca la contraseña en la consola de ECS.
- Si el problema es el resultado de la causa 2, proceda de la siguiente manera:
- Busque la fila que contiene el ECS de destino, haga clic en More en la columna Operation y seleccione Restart.
- Utilice el archivo clave para volver a iniciar sesión en el ECS y compruebe si el inicio de sesión es correcto.
- Si el inicio de sesión tiene éxito, no se requiere ninguna otra acción.
- Si el inicio de sesión falla, póngase en contacto con el servicio de atención al cliente para obtener soporte técnico.