Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Centro de ayuda/ Elastic Cloud Server/ Preguntas frecuentes/ Disk Management/ Disk Partitions and Virtual Memory/ ¿Qué debo hacer si el disco de datos conectado a un ECS de Windows no está disponible?
Actualización más reciente 2023-08-08 GMT+08:00

¿Qué debo hacer si el disco de datos conectado a un ECS de Windows no está disponible?

Síntomas

Después de iniciar sesión en mi ECS de Windows, no puedo encontrar el disco de datos adjunto.

Formatear un disco causará la pérdida de datos. Por lo tanto, antes de formatear un disco, cree una copia de respaldo para él.

Causas posibles

  • Un disco de datos recién agregado no se ha particionado ni inicializado.
  • El disco se desconecta después de cambiar el SO de ECS o de modificar las especificaciones de ECS.

El disco de datos recién agregado no ha sido particionado o inicializado

Un nuevo disco de datos no tiene particiones ni sistemas de archivos de forma predeterminada. Por eso My Computer no está disponible. Para resolver este problema, inicialice manualmente el disco.

Para obtener más información, consulte Introducción a escenarios de inicialización de disco de datos y estilos de partición.

Disco se desconecta después de que se cambie el SO de ECS o se modifiquen las especificaciones de ECS

Después de cambiar el SO del ECS, es posible que los discos de datos no estén disponibles debido a la inconsistencia del sistema de archivos. Después de modificar las especificaciones de un ECS de Windows, los discos de datos pueden estar fuera de línea.

  1. Inicie sesión en ECS, abra la ventana cmd y escriba diskmgmt.msc para cambiar a la página Disk Management.

    Compruebe si el disco afectado está sin conexión.

  2. Establezca el disco afectado para que esté en línea.
    En la lista de discos, haga clic con el botón derecho en el disco afectado y elija Online en el menú contextual para ponerlo en línea.
    Figura 1 Configuración del disco en línea
  3. En el My Computer, compruebe si el disco de datos se muestra correctamente.

    Si la falla persiste, inicialice y particione el disco de nuevo. Antes de inicializar el disco, cree una copia de respaldo para él.