¿Por qué el SO no responde cuando se produce kdump en un ECS de Linux?
Síntomas
Cuando se produce kdump en un ECS de Xen Linux, el SO no responde y no se puede recuperar automáticamente. Por ejemplo, si ejecuta el comando echo c>/proc/sysrq-trigger para activar kdump, se produce este error.
Generalmente, kdump está deshabilitado para imágenes públicas. Este problema no se produce en los ECS creados con las imágenes públicas.
Causas posibles
- Ciertas versiones del kernel de Linux son incompatibles con la virtualización de Xen.
- Si kdump está habilitado en el ECS con el núcleo que no soporta soft_rest, el ECS deja de responder durante el volcado.
Solución
Método 1: Deshabilidad de kdump.
Tome CentOS 7.2 como ejemplo.
- Reiniciar a la fuerza el ECS.
- Inicie sesión en la consola de gestión.
- En Compute, haga clic en Elastic Cloud Server.
- Seleccione el ECS de destino y haga clic en Restart.
- Seleccione Forcibly restart the preceding ECSs o Forcibly stop the preceding ECSs.
- Haga clic en OK.
- Deshabilitar kdump.
Método 2:
Si el ECS de destino admite la función crash_kexec_post_notifiers, agregue la función al archivo de configuración de inicio de ECS (menu.lst o grub.cfg). Para ello, haga lo siguiente:
- Ejecute el siguiente comando para comprobar si ECS admite la función crash_kexec_post_notifiers:
cat /proc/kallsyms |grep crash_kexec_post_notifiers
Figura 2 Soporte para la función crash_kexec_post_notifiers
- En caso afirmativo, vaya al paso 2.
- Si no, utilice el método 1.
- Agregue la función crash_kexec_post_notifiers al archivo de configuración de inicio.
Tome a menu.lst como ejemplo.