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Why Does the System Display Error Code 0x1104 When I Log In to a Windows ECS?
Actualización más reciente 2023-08-08 GMT+08:00
Why Does the System Display Error Code 0x1104 When I Log In to a Windows ECS?
Symptom
The system displays an error message indicating that a protocol error (code: 0x1104) is detected when you use MSTSC to access an ECS running Windows Server 2008.
Figura 1 Protocol error (code: 0x1104)
![](https://support.huaweicloud.com/intl/es-us/ecs_faq/es-us_image_0288997598.png)
Possible Causes
- Port 3389 of the security group on the ECS is disabled.
- The firewall on the ECS is disabled.
- Port 3389 on the ECS is used by other processes.
- The Remote Desktop Session Host is incorrectly configured.
Solution
- Check security group settings.
Check whether port 3389 is allowed in inbound direction. If it is allowed, go to 2.
- Check whether the firewall is disabled:
- Log in to the Windows ECS.
- Click the Windows icon in the lower left corner of the desktop and choose Control Panel > Windows Firewall.
- Click Turn Windows Firewall on or off.
View and set the firewall status.
If the firewall is enabled, go to 3.
- Log in to the ECS using VNC and check the port.
- Open the cmd window and run the following command:
netstat -ano |findstr: 3389
As shown in Figura 2, port 3389 is used by the process with ID of 4.
- Open Task Manager and find the process with ID of 4 is the System process.
- Generally, the IIS and SQL Server run as the System process. Run the following HTTP command for further check.
Figura 3 Checking System process
- If port 3389 is used by HTTP protocols, it indicates that the port is used by IIS.
- Enter http://127.0.0.1:3389 in the address box of the browser and press Enter. Check whether the website can be visited normally.
- Change the port used by IIS and restart IIS.
- Open the cmd window and run the following command:
- If no error occurs during the preceding steps, go to step 5 to check whether error 0x1104 is caused by the configuration of Remote Desktop Session Host.
- Check the remote desktop session host configuration.
- Log in to the ECS using VNC.
- Open the cmd window and enter gpedit.msc.
- Click OK to start Local Group Policy Editor.
- Choose Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services.
Figura 4 Remote Desktop Services
- Remote Desktop Session Host > Security.
Figura 5 Remote (RDP) Connection requires the use of the specified security layer
- Set Require use of specific security layer for remote (RDP) connections to Enabled and Security layer to RDP.
Figura 6 Setting security layer
- Click OK.
- After the configuration is complete, open the cmd window.
- Run the following command to update the group policy:
Figura 7 Updating the group policy
Tema principal: Remote Login Errors on Windows
Remote Login Errors on Windows Preguntas frecuentes
- ¿Por qué ocurre un error de autenticación después de intentar iniciar sesión de forma remota en un ECS de Windows?
- ¿Por qué no puedo usar el equipo local para conectar a mi ECS de Windows?
- How Can I Obtain the Permission to Remotely Log In to a Windows ECS?
- ¿Por qué el sistema no muestra Remote Desktop License Servers disponibles para proporcionar una licencia cuando inicio sesión en un ECS de Windows?
- ¿Por qué el sistema muestra el código de error 0x112f cuando inicio sesión en un ECS de Windows?
- Why Does the System Display Error Code 0x1104 When I Log In to a Windows ECS?
- Why Does the System Display Error Code 122.112.. When I Log In to a Windows ECS?
- Why Does the System Display Invalid Certificate or Associated Chain When I Log In to a Windows ECS from a Mac?
- ¿Por qué el sistema muestra un mensaje que indica credenciales no válidas cuando intento acceder a un ECS de Windows?
- Why Does an Internal Error Occur When I Log In to My Windows ECS?
- Why Is My Remote Session Interrupted by a Protocol Error?
- Why Am I Seeing an Error Message That Says Identity of Remote Computer Cannot be Verified When I Log In to a Windows ECS?
- Why Am I Seeing An Error Message That Says The Two Computers Couldn't Be Connected in the Amount of Time Allotted When I Log In to a Windows ECS?
- ¿Por qué veo un mensaje de error que dice que la cuenta de usuario no está autorizada para el inicio de sesión remoto cuando inicio sesión en un ECS de Windows?
- Why Does My Remote Desktop Session End Because Another User Logs In When I Log In to a Windows ECS?
- ¿Por qué ocurre BSOD cuando inicio sesión en un ECS mediante la conexión al escritorio remoto?
- Why Does an ECS Fail to Be Remotely Connected Using RDP and Internal Error Code 4 Is Displayed?
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