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Actualización más reciente 2024-09-13 GMT+08:00

¿Cómo manejo el fallo en la sustitución de un par de claves?

Síntoma

Error al reemplazar el par de claves en el ECS.

El cuadro de diálogo Failed Key Pair Task sólo registra y muestra las operaciones de par de claves fallidas en los ECS, que no afectan al estado ECS ni a las operaciones posteriores. Puede hacer clic en Delete en la fila del registro de error para eliminarlo, o puede hacer clic en Delete All para eliminar todos los registros de error.

Causas posibles

  • Se ha proporcionado una clave privada incorrecta o no válida.
  • La dirección de entrada del puerto 22 del grupo de seguridad ECS no está abierta a 100.125.0.0/16.
  • Se ha modificado la configuración SSH del ECS.
  • El ECS se ha apagado, iniciado o se ha separado un disco durante el proceso de sustitución del par de claves para el ECS.
  • La conexión de red es defectuosa.
  • Las reglas de firewall se han configurado para el ECS.

Procedimiento de manejo

  1. Utilice el par de claves SSH para iniciar sesión en el ECS y compruebe si la clave privada es correcta.

    • Si es correcto, vaya a Paso 2.
    • Si no es correcto, utilice la clave privada correcta para reemplazar el par de claves.

  2. Compruebe si el archivo /root/.ssh/authorized_keys del ECS ha sido modificado.

    • En caso afirmativo, restaure el contenido original del archivo /root/.ssh/authorized_keys según los requisitos del sitio.
    • Si no, vaya a Paso 3.

  3. Compruebe si la dirección de entrada del puerto 22 del grupo de seguridad ECS está abierta a 100.125.0.0/16. Es decir, 100.125.0.0/16 puede conectarse remotamente a los ECS de Linux a través de SSH.

    • En caso afirmativo, vaya a Paso 4.
    • Si no, agregue la siguiente regla de grupo de seguridad y reemplace el par de claves.

      Dirección

      Protocolo/Aplicación

      Puerto

      Origen

      Inbound

      SSH (22)

      22

      0.0.0.0/0

  4. Compruebe si el ECS se puede encender, apagar e iniciar sesión.

    • Si es así, vuelva a sustituir el par de claves.
    • Si no, vaya a Paso 5.

  5. Compruebe si la red está defectuosa.

    • En caso afirmativo, póngase en contacto con el soporte técnico para verificar y localizar la falla.
    • Si no, vuelva a cambiar el par de claves.