Help Center/ DataArts Studio/ FAQs/ Consultation and Billing/ Why Does the System Display a Message Indicating that the Number of Daily Executed Nodes Has Reached the Upper Limit? What Should I Do?
Updated on 2024-11-05 GMT+08:00

Why Does the System Display a Message Indicating that the Number of Daily Executed Nodes Has Reached the Upper Limit? What Should I Do?

The number of daily executed nodes is the maximum scheduling times per day for job nodes in different versions of DataArts Studio instances. For details about the quota differences between the versions, see DataArts Studio Versions.

Possible Causes

This message is displayed when the sum of the number of nodes that have been executed, that of nodes that are being executed, and that of nodes to be executed on a day have reached the upper limit of the quota.

Solution

If the number of daily executed nodes exceeds the upper limit, it may be caused by frequent job scheduling.

1. Buy a job node scheduling times/day incremental package to increase the quota. For details, see Buying a Job Node Scheduling Times/Day Incremental Package.

2. You can perform the following operations to check for the job nodes that are scheduled more frequently than others, and adjust the scheduling cycles for these nodes or stop scheduling them.
  1. In the left navigation tree of Data Development, choose Monitoring > Monitor Instance, select the current day, and view the jobs that are frequently scheduled.
  2. In the left navigation tree of Data Development, choose Monitoring > Monitor Job to check whether the scheduling period of jobs that are frequently scheduled is set properly. If the scheduling period is inappropriate, adjust the scheduling period or stop the scheduling. Generally, the number of minute-level scheduling jobs executed every day exceeds the upper limit.
    Figure 1 Viewing the scheduling period